Targeting delay with new challenges
Incident Report for Influitive
Resolved
Our targeting system has been repaired and has mostly caught up on its backlog. The calculation of new challenge / targeting visibility should be back to the normal wait time.

We will continue to monitor closely throughout to ensure everything is working as expected.
Posted about 1 month ago. May 23, 2017 - 15:04 UTC
Investigating
Targeting is significantly delayed when creating and publishing new challenges. Our engineers are working on resolving this as soon as possible. We'll provide updates as we find out more.
Posted about 1 month ago. May 23, 2017 - 13:07 UTC