Targeting Delay - June 6th
Incident Report for Influitive
Resolved
The targeting issues have been resolved, all your targeting should now be accurate.

Please contact Support if you continue to experience delays.
Posted 6 months ago. Jun 07, 2017 - 11:00 UTC
Investigating
Targeting is significantly delayed when creating and publishing new challenges. Our engineers are working on resolving this as soon as possible. We'll provide updates as we find out more.
Posted 6 months ago. Jun 06, 2017 - 23:37 UTC