AdvocateHub is currently down
Incident Report for Influitive
Resolved
This incident has been resolved. AdvocateHub is operational.
Posted Jan 24, 2020 - 16:00 EST
Investigating
We are currently investigating the issue. We will update shortly.
Posted Jan 24, 2020 - 15:52 EST
This incident affected: Advocate Hub, Discussions, Targeting, Link Sharing, and API.