Referral forms not loading
Incident Report for Influitive
Resolved
A fix has been implemented for the referrals feature, and everything should be back to normal. We apologize for any lost productivity during this time.
Posted Jul 12, 2019 - 11:01 EDT
Investigating
You and your advocates may find that that referral forms are not loading on the Referrals tab in your AdvocateHub or on other referrals campaigns you may have created.

We understand that having a working referrals form is of the utmost importance, so our engineering team is working hard to resolve this issue.
Posted Jul 12, 2019 - 10:36 EDT
This incident affected: Advocate Hub.